You must be logged in to use the forums. Don't have an account? Sign up for free.
Remember me
Snoobster
#0 September 8th, 09:40

Establishing connection

Problems booting up today again. Been stuck in Establishing connection for 30+ mins now. Is there anything I can do?

Showing 1-15 of 15 comments
Snoobster
#1 September 8th, 09:47
And now it powered off automatically.

Staff
#2 September 8th, 10:17
If it's "Establishing connection", it means that it somehow is unable to pair your computer to the cloud rig. Did you try to close/open the Chrome extension? This has worked for some users with similar issues.

Snoobster
#3 September 8th, 11:55
That didn't help. Same thing, and now its powered off again.

Snoobster
#4 September 8th, 14:21
I am giving it an another try right now. Please let me know if there is something else I can do, or should do.

Snoobster
#5 September 9th, 23:15
same thing today. No booting for a few days now.

Moderator
#6 September 10th, 02:03
Hi Andy,

Sorry to hear you're having connection issues. We are working toward a fix that should be implemented within a few weeks at most. For the time being, a temporary work around has worked for many users. Closing and reopening the Chrome extension after about 2-3 minutes of letting it sit at the stuck process seems to work. Try this a few times and let me know if you can bypass this issue.

Thanks!

Snoobster
#7 September 11th, 07:13
Hey just signed up tonight, and immediately installed parsec. If you guys can keep the current pricing structure you have won me over from LiquidSky, this is my biggest problem with cloud gaming, if you can't have unlimited access for a reasonable monthly fee its just not worth it, and you guys are only wanting £30/m for unlimited. No Arguments from me, once i got past the initial connect issues, I love it! :)

Snoobster
#8 September 11th, 07:53
@Curivity I already tried that, and it didn't help. I will try it a final time today.

Snoobster
#9 September 11th, 08:12
Andy let it sit and say establishing connection for a few mins, then quit and open snoost again and it should connect within 20-30 seconds, if it doesn't rinse-repeat basically, Thats what worked for me, id then suggest you do as I did open windows and install parsec it works great on the Snoost service and I don't get any drop-outs. Just my 2-cents.

Snoobster
#10 September 12th, 09:57
@DeedsCali Wow. Thanks! It worked! Although my steam account was erased, its a great step forward. :-)

Snoobster
#11 September 12th, 17:34
@DeedsCali
Hey just signed up tonight, and immediately installed parsec. - DeedsCali
I tried this too and it worked great.

But when I came back next time Parsec was gone.

Do installed programs get deleted when you log off or did I do something wrong?

Game reviewer
#12 October 9th, 19:37
Problems booting up today again. Been stuck in Establishing connection for 30+ mins now. Is there anything I can do? - andy
HI i need help mine says paring to cloud rig failed plzz help

Game reviewer
#13 October 9th, 19:54
HI i need help mine says paring to cloud rig failed plzz help

Staff
#14 October 9th, 20:03
@BRZKToast we are currently working to solve the pairing issues (these are related to the establishing connection problem you are experiencing). Closing and re-opening the client may fix the bug temporarily. We'll keep you updated on any news and progress related to this issue. Thank you for your patience.

Staff
#15 October 13th, 10:28
We have just published a patch which addresses these issues. Thanks for the feedback!

Showing 1-15 of 15 comments