You must be logged in to use the forums.
Remember me
#0 June 28th 2017, 15:24

Total War: Warhammer launcher issues

Just for anybody trying to play this game, there are some issues with it, the developers are working on a fix and I have found a way to work around the issue and play the game (although it is a time consuming process needed to be repaeted every time you wish to play)

Last week i joined Snoost and bought Total War: Warhammer. When i first istalled the game on the cloud rig it started up just fine and i was able to start and play the game without any issues. The next day it would not launch the game. When i was looking online for awnsers the steam forum showed some gamers with similair issues. One person stated a solution:

-right click on start button and select run -type %appdata% -go to The Creative Assembly folder and then Warhammer -open the logs folder and delete Modified.log then click back -open the scripts folder and delete Prefrences.script.txt -then close the folder and completely exit steam -then reload steam and you should be able to start the game.

When i tried this in the windows stream on the cloud rig. i noticed that the scripts folder was empty so i was not able to delete te Preference.script.txt. by just deleting the Modified.log i was not able to launch the game. Someone stated that the issues will be fixed if you download a previous patch for the game, so i did and it stasrted after the download but i lost my saved games. The next day it failed to launch again ( even though i selected the option to not automaticly update the game and it stayed on the previous patch number i installed the day before) Again the composition of the folders stated in the solution above did not change)

Another person stated different solution:

-Open Steam -Select the Total War: Warhammer game in the library. -Select manage game -Secect the option vailidate content -After this, steam will start the proces of downloading the files that seem to be missing in order to launch the game.

After this download, the game was able to launch, but again i have lost my saved games.

The next day the game did not launch again. Do note that i have used the proper way of exiting the cloud rig by turning it of and letting it save. So i repeated the proces of validating the content and it was able to laucnch again after the 7,4GB download started by the validation process. By this time i was smart enough to have saved my game ion the Steam Cloud so i was able to continiue my game progress. When i quit the game after playing, i started the windows stream for the cloud rig. I opened the Creative Assembly folder through running %appdata% in start. I noticed that the Total War: Warhammer folder was with with loads of sub folders i had never seen before. Before starting the game ( when it fails to launch properly) the Total Warhammer folder contains only three subfolders. After validating and downloading and launching as stated above, the folder contains many subfolders. I do not remember al the names of the folders it contained but there were well over 20. Off course the next day when i tried to launch the game it failed again and the Total War: Warhammer folder was back to its previous state containing only three sub folders. Also note that these issues do not occur with other Total War games, just Warhammer

It seems to me that it just might be that the game needs all of these folders in order to launch, but for some reason the rig does not save them when i turn off the rig.

For now the steps stated above (validation process) seem to be necesairy every time i try to launch the game. It is a time consuming proces but at least it works. As for Snoost running the game.... just great. No complaints there. It would be great if a fix comes for Total War Warhammer because the sequal is being released in a few months and i plan to play that one till i drop ;) Of course with Snoost as my gaming platform!

Last edited: July 5th 2017, 03:52

Showing 1-6 of 6 comments
#1 July 1st 2017, 15:16
It looks like the guys at development fixed the issue!

Thanks a lot!!

#2 July 3rd 2017, 10:54
@koekiskoek We're glad you liked the update. :) We are still working on more solid synchronisation of game files, and are currently rolling out a few more optimisations for other games than just Warhammer: Total War, which should result in a much smoother cloud gaming experience.

Also, we apologise for the delayed response, but thank you for the detailed bug report. It really helped us track down the issue, and will hopefully help other users in a similar situation.

#3 July 3rd 2017, 23:22
Hi Rune! Thanks a lot for adressing the issue. I did notice that over the last couple of days some save files have gone missing when I start the game, and I did have the not launching issue again after my rig suddenly shut down on his own and started saving. I has done that a couple of times before. When it's done, I'm back in the que again.

Do you know why this is and if those issues are related?


#4 July 4th 2017, 23:07

Im having issues with the game again. It keeps closing down and then i see a windows error that the game has closed down because the program is not working correctly, due to a problem.

I have had similair errors in the last couple of days now, where the game just closes down and gives me the same error , while it has worked just fine last week, after the update. Again, the only way to start after these errors playing is by validating the content of the game (in steam) and update again.

The error has occured on the following occasions, spread out over 2 different gaming sessions:

-when i launched the game yesterday, i got the error and had to reinstal an update to play - session 1 -while i was playing yesterday later that evening it just closed down. and i got the same error. I just powered of the rig and let it save -session 1 -just now when i started up the rig and tried to start the game, it launched but cloed down while in game menu and kept doing this, downloaded the update again - session 2

Can you please fix the issue?


Last edited: July 4th 2017, 23:29

#5 July 5th 2017, 09:36
@koekiskoek Again, thanks for the amazing bug reports.

The issues aren't related, but this last issue is likely due to the gamefiles not all being synchronised correctly, which could cause certain files to be missing and thus require a "validation of files" in Steam for the game to work again.

We will do our best to address the synchronisation issues as soon as possible.

Do you remember which region your server was located in (e.g. if it was Central or West Europe)?

#6 July 5th 2017, 12:24
Hi Rune, Thanks for the quick reply!! I belive it was Central Europe

Hopefully the issue will be fixed, thanks again and have a nice day!

Last edited: July 5th 2017, 12:24

Showing 1-6 of 6 comments